OS 1.2.0.2

The Dave Smith Instruments Pro 2 Analogue Synthesizer

Moderator: Pym

Post Reply
mr_rock
Posts: 8
Joined: Wed Sep 17, 2014 2:22 am

OS 1.2.0.2

Post by mr_rock » Sat Apr 16, 2016 10:59 am

Completed the 1.2.0.2 OS update this morning.

A couple things I found so far:
  • Updating via MIDI did not work. At the end of the transfer, the screen went static-ish. I tried this several times and finally updated via USB.
  • The LFO lights no longer function as they used to. They stay lit if a triangle waveform is selected, but are off for the other waveforms. They no longer track the LFOs.
  • MIDI clock sync seems more stable (less jiggling BPM) up to about 150 BPM, but it still jumps around. By comparison, my Nord Lead 3 tracks solid up to about 265 BPM.
Otherwise, so far so good. :)
DSI Evo DT #198, Pro 2 #337, MEK #896, Tempest #3425 // Yamaha AN1X, RY30, RM1X // Nord Lead 3 // Virus Classic

My recordings: https://soundcloud.com/fuzzys-dead-mouse

User avatar
nielsd
Posts: 79
Joined: Sun Sep 06, 2015 1:28 pm
Location: Göttingen / DE
Contact:

Re: OS 1.2.0.2

Post by nielsd » Sat Apr 16, 2016 11:20 am

Sorry, but where did you found the download / new firmware blob?

many thanx,

Niels.
Niels Dettenbach
dettenbach audio
music fab
http://dettenbach.de

User avatar
nielsd
Posts: 79
Joined: Sun Sep 06, 2015 1:28 pm
Location: Göttingen / DE
Contact:

Re: OS 1.2.0.2

Post by nielsd » Sat Apr 16, 2016 1:15 pm

..ahh, found it on the public page (expected it somewhere here in the forum "as usual" for "betas" ß).

sorry for the noise...

User avatar
nielsd
Posts: 79
Joined: Sun Sep 06, 2015 1:28 pm
Location: Göttingen / DE
Contact:

Re: OS 1.2.0.2

Post by nielsd » Sat Apr 16, 2016 1:37 pm

The LFO lights no longer function as they used to. They stay lit if a triangle waveform is selected, but are off for the other waveforms. They no longer track the LFOs.
...hmm, for me they "track" the LFO, but they only show two or three steps of light, but doesn't go fully off (except in square and random). This means the LEDs show the "frequency", but you have to look closely to see it.

It would be nice to have the LEDS "tracking" a bit more visible - i.e. by lowering the LED-current for (steps - the current seems stepped) "lower" values a bit...
Niels Dettenbach
dettenbach audio
music fab
http://dettenbach.de

RKfan
Posts: 9
Joined: Mon Jun 15, 2015 6:59 pm

Re: OS 1.2.0.2

Post by RKfan » Sat Apr 16, 2016 5:20 pm

I really like the ability to assign an LFO to delay time all - gives some interesting effects

User avatar
sbookholt
Posts: 435
Joined: Sat Jan 28, 2012 10:42 pm
Location: Utrecht
Contact:

Re: OS 1.2.0.2

Post by sbookholt » Sun Apr 17, 2016 3:39 pm

I can't find what's new in os 1.2. Anyone know where the release notes are?

mr_rock
Posts: 8
Joined: Wed Sep 17, 2014 2:22 am

Re: OS 1.2.0.2

Post by mr_rock » Sun Apr 17, 2016 7:25 pm

There is an addendum on the DSI site that addresses the new OS :

http://www.davesmithinstruments.com/wp- ... pdf?b54397
The LFO lights no longer function as they used to. They stay lit if a triangle waveform is selected, but are off for the other waveforms. They no longer track the LFOs.
LFO lights are operating as before. Seems my Pro 2 needed to be turned off, despite it's own post-upgrade reset.

Loving the new "osc all shape mod" destination, especially for pads...
DSI Evo DT #198, Pro 2 #337, MEK #896, Tempest #3425 // Yamaha AN1X, RY30, RM1X // Nord Lead 3 // Virus Classic

My recordings: https://soundcloud.com/fuzzys-dead-mouse

Post Reply