Pro2 Main 1.1.15

The Dave Smith Instruments Pro 2 Analogue Synthesizer

Moderator: Pym

Pym
Posts: 2197
Joined: Thu Mar 11, 2010 6:24 am
Location: San Francisco, CA
Contact:

Pro2 Main 1.1.15

Post by Pym » Thu Jul 23, 2015 7:40 pm

ALWAYS BACKUP YOUR IMPORTANT WORK VIA SYSEX DUMP BEFORE ATTEMPTING ANY OS UPDATES!!
Not that we're expecting bad things to happen, but always better safe than sorry. Just remember, you're never going to say to yourself "Man, I wish I hadn't backed that up..."

We do not recommend using the following MIDI interfaces for sysex transfers as we have had multiple users experience problems with them:
  • Native Instruments Maschine
  • Digidesign Mbox/Mbox2
  • Digidesign 001/002
  • CME U2MIDI
Updating the Pro 2 OS on a PC
Updating the Pro 2 OS on a Mac

To check if the OS update was properly installed, go to the global menu by hitting the 'Global' button and the OS version is displayed at the top of the 3rd column

If your OS update failed:
  • Update your MIDI drivers for your MIDI interface to the latest or last known stable version
  • Try alternate speed settings: transfer speed settings as low as 25% and as high as 100% have worked for some users when 80% did not
  • Try an alternate MIDI interface. The M-Audio MIDI Sport Uno works well here and is relatively cheap
  • In Windows with MIDI OX on Windows XP: Try doubling or quadrupling the Size setting to start, and halving/doubling the number of buffers
  • Search google and/or forums for the company that produces your MIDI interface to see if other users are having similar problems with Sysex transfers and whether there is a solution specific to your interface
  • If you are on Windows XP, try another OS or machine. Although it's not ideal, we have had less problems with Mac OSX and Windows 7. Windows XP has known issues with sysex transfers
INSTALLATION NOTE: It is recommended to recalibrate the filters and reset globals after installing a Main OS update. These functions can be found in the global menu

Main OS 1.1.15
  1. Production Candidate
  2. Fixed bug: Using show with passthru pot mode not working correctly
  3. Fixed bug: When restart off, using reset on the sequencer then pressing play does not start sequence right away
  4. Fixed bug: Arp key scan error
  5. Fixed bug: hold does not work in key seq mode with env/trig off
  6. Fixed bug: Mod matrix bug with source set to off but amount/destination valid affecting previous valid source in list
Main OS 1.1.14
  1. Production Candidate
  2. Fixed bug: Tying a note sometimes causing hung notes over MIDI
  3. Fixed bug: When local control off, program changes not sent correctly
  4. Fixed bug: When sequencer set to notes off, hold not holding played notes
  5. Fixed bug: When sequencer set to notes off, sequence and gate source set to keyboard, only sequencer is started
  6. Fixed bug: When sequencer playing, seq button held and a note is played, sometimes note hangs
  7. Fixed bug: When play source not seq/key, gate source not same source as play source, step mode, env trig off, Sequencer tracks do not update voice
  8. Fixed bug: When MIDI Out set to USB or MIDI+USB, Pro 2 not responding to sysex messages
  9. Fixed bug: No response to universal device inquiry from OSX
  10. Fixed bug: When sysex cable set to USB, clock mode slave, clock cable set to USB, no response to sysex messages
  11. Fixed bug: Arp button toggles arp when pressed even when not on the arp screen, now brings you to screen first without toggle
  12. Fixed bug: When arp to midi on and arp on, only note off messages sent to MIDI output
  13. Removed global entry for alternate tunings as it is not currently functional
Main OS 1.1.8
  1. Sequencer Track 1 can now be turned to 'Off': To disable, hold track select and press 'Notes: On' button to toggle
  2. Can now copy/paste data between tracks: hold track select, press 'Copy Track' button, then press 1-16 button to copy to that track
  3. Added new mod destinations for Osc All Shape Mod, Osc 1-4 Slop, and Delay All Time
  4. Foot pedal can now be used to start/stop sequencer
  5. Added new cable options for 'MIDI Clock Out' so you can send clock to MIDI Out 1, USB, 2, or 1+2
  6. Sequencer now sends MIDI Start/Stop transport controls by default
  7. Added Slave No Start/Stop option to MIDI Clock Mode to ignore Start/Stop messages
  8. Added new globals:
    • OLED screen saver on/off
    • Alternate Tunings (note: not working yet)
    • MIDI Arp notes
    • MIDI Program change
  9. Fixed bug: OLED screen never turns off
  10. Fixed bug: Many small sequencer bugs that occur only when specific modes/params are set and actions are triggered
  11. Fixed bug: 11K noise on repeating envelopes
  12. Fixed bug: Realtime recording sync'd Delay pot not recording correct boundaries
  13. Fixed bug: Quarter triplets and 16th triplets slightly off in timing in LFOs
  14. Fixed bug: CV not limited when sequencer source causing refresh problems, now limited to max BPM refresh rate
  15. Fixed bug: When write is active, pressing sequencer exits write but leaves LED on
  16. Fixed bug: When sequencer track has no destination steps can still be recorded to
  17. Fixed bug: When all oscillators selected, live recording of pulse width knob assigns osc all slop to seq track
  18. Fixed bug: When sequencer 32x8, holding 'step 1-16' button and hitting reset causes reset to be set on step 18
  19. Fixed bug: Bank number not stored in playlist after powerdown
  20. Fixed bug: All envelope select screen shows wrong params when Env 5 destination is changed
  21. Fixed bug: Program changes sent on wrong MIDI channel
  22. Fixed bug: Cue/playlist sets 3+4 do not save bank
  23. Fixed bug: Pitch/Mod Wheel and Sliders still send CC when Param Send Off
  24. Fixed bug: Mod wheel occasionally sends a MIDI Reset message when returned to the 0 position
  25. Fixed bug: Revert all not refreshing arp LED
  26. Fixed bug: Delay still outputting in stereo when global set to mono
  27. Fixed bug: Sine waveshape graphic not changing when shape mod changed
  28. Fixed bug: When sequencer in playback, holding a tied step button and pressing a key transposing sequencer, should not do this
  29. Fixed bug: Super waves do not sound correct when modulated, range increased
  30. Fixed bug: Cueing sequenced programs loses sync when externally sync'd
  31. Fixed bug: When pots set to passthru, using 'show' button caused odd behavior and flickering
  32. Fixed bug: Volume pedal changes not persisting across preset changes
  33. Fixed bug: Arp playing first note one too many times when repeat set to value other than 0
  34. Fixed bug: Arp not resetting octave correctly depending on timing
Main OS 1.1.0
  1. Fixed bug: When show on, step value/slew and delay time knobs not showing the correct screen
  2. Fixed bug: When in cue/playlist unable to get into global menu
  3. Fixed bug: If you select an env amount in sequencer as a destination changed display to say 'F1 Env Amt' instead of 'F1 Env' for clarity
  4. Fixed bug: Added page numbers to all LFO and OSC screens
  5. Fixed bug: Osc Wave Reset and Key Follow not consistently displayed in boxes
  6. Fixed bug: Sequencer and arp can be turned on simultaneously via NRPN resulting in odd behavior
  7. Fixed bug: Compare now turns off when basic program initialized
  8. Fixed bug: When playing a 'play once' sequence with sequencer as sequencer source, play button should stop/pause the sequence
  9. Fixed bug: Seq 1 mod source not sending note value
  10. Fixed bug: Reset triggers on button down AND button up when play mode set to step
  11. Fixed bug: Unable to turn sequencer off while in cue/playlist
  12. Fixed bug: Many sequencer bugs where combinations of parameters and actions did not act as intended
  13. Fixed bug: OS writing screen garbled sometimes
  14. Fixed bug: Track 1 with all steps rested not acting as intended
  15. Fixed bug: Entering notes in a tied step not entering in the correct location in the tied note
  16. Fixed bug: Ext audio not triggering during state transitions (writing program, turning sequencer on/off, changing gate source, etc)
  17. Fixed bug: When track select held, dedicated slew pot sets track velocity value rather than slew
  18. Fixed bug: Fixed saving cue programs in cue screen with soft encoders
  19. Fixed bug: When play source ext in/cv and play mode step, high signal should always step sequencer
  20. Fixed bug: Hold step 1-16/17-32 button and hitting reset should set all track reset points to 17 or 33 respectively
  21. Fixed bug: When track select is held, character section should be assigned to track when character button pressed
  22. Fixed bug: When clock is set to slave and MIDI port, front panel controls and screen refresh becomes sluggish after a period of time
  23. Fixed bug: 11K noise on repeating VCA envelopes
Attachments
Pro2_Main_1.1.15.syx
Pro 2 Main Beta OS 1.1.15
(585.51 KiB) Downloaded 358 times
Pro_2_Main_1.1.0.syx
Pro 2 Main Production OS 1.1.0
(585.51 KiB) Downloaded 132 times
Chris Hector
https://soundcloud.com/iampym
Dave Smith Instruments

Pym
Posts: 2197
Joined: Thu Mar 11, 2010 6:24 am
Location: San Francisco, CA
Contact:

Re: Pro2 Main 1.1.0

Post by Pym » Thu Jul 23, 2015 7:52 pm

Just making this official since we're going to release a new bug fix OS soon

I'm not outlining exactly all the sequencer related bugs we've been fixing since there are a LOT of them and they're all only visible if you use certain combinations of parameters and triggers, would take dozens of lines to put them all out there
Chris Hector
https://soundcloud.com/iampym
Dave Smith Instruments

Pym
Posts: 2197
Joined: Thu Mar 11, 2010 6:24 am
Location: San Francisco, CA
Contact:

Re: Pro2 Main 1.1.8

Post by Pym » Thu Jul 23, 2015 9:48 pm

New OS posted. Adds a few features (sequencer copy/paste, sequencer 1 off, new mods, some globals) and a bunch of minor bug fixes
Chris Hector
https://soundcloud.com/iampym
Dave Smith Instruments

Benzebub
Posts: 118
Joined: Sun Jun 23, 2013 5:04 pm

Re: Pro2 Main 1.1.8

Post by Benzebub » Thu Jul 23, 2015 10:47 pm

Wow! Thanks a lot Pym!
Will try this one out. :)

User avatar
elmquist
Posts: 3121
Joined: Thu Jun 24, 2010 8:35 am
Location: Denmark

Re: Pro2 Main 1.1.8

Post by elmquist » Thu Jul 23, 2015 11:25 pm

Minor detail: "Pro 12" -> "Pro 2"

blewis
Posts: 219
Joined: Sun Sep 29, 2013 7:11 pm

Re: Pro2 Main 1.1.8

Post by blewis » Fri Jul 24, 2015 3:35 am

YES! THANKS! CAN'T WAIT TO TRY

User avatar
BobTheDog
Posts: 1156
Joined: Sun Nov 20, 2011 8:49 pm

Re: Pro2 Main 1.1.8

Post by BobTheDog » Fri Jul 24, 2015 9:06 am

Hi, Thanks for the update.

Should the Seq Out n Ch n stuff be working?

ogdanks
Posts: 5
Joined: Wed Feb 18, 2015 11:15 pm

Re: Pro2 Main 1.1.8

Post by ogdanks » Fri Jul 24, 2015 1:36 pm

Thanks for the update! Can't wait to test it out!

justs
Posts: 1
Joined: Fri Jul 24, 2015 2:25 pm

Re: Pro2 Main 1.1.8

Post by justs » Fri Jul 24, 2015 2:35 pm

I've updated my Pro2 successful to OS 1.1.8

But i have some strange Midi-Clock behavior:
The Pro 2 is set up via USB as slave in Ableton 9.2 64Bit.
If i'm running Ableton Live with 120bpm my Pro 2 is receiving something like 232bpm.

In the other direction, Pro 2 via USB Midi-Clock setup as Master running 120bpm, Ableton is receiving about 210bpm.

It seems that the Midi-Clock itself work proper (Sequencer and Arp are in sync with the DAW) but the values in the display on the Pro2 are total wrong.

Can someone please confirm this.

cbmd
Posts: 346
Joined: Fri Sep 30, 2011 11:49 pm

Re: Pro2 Main 1.1.8

Post by cbmd » Fri Jul 24, 2015 5:12 pm

Yup that's a bug. I'll add it to the list. Thanks!
Carson Day
Technical Support
Dave Smith Instruments

User avatar
sbookholt
Posts: 435
Joined: Sat Jan 28, 2012 10:42 pm
Location: Utrecht
Contact:

Re: Pro2 Main 1.1.8

Post by sbookholt » Fri Jul 24, 2015 5:20 pm

Thats quite a big list, great work! Hope linear fm and the fixed mod destination shortcut is still on the agenda 8)

Benzebub
Posts: 118
Joined: Sun Jun 23, 2013 5:04 pm

Re: Pro2 Main 1.1.8

Post by Benzebub » Fri Jul 24, 2015 10:10 pm

sbookholt wrote:Thats quite a big list, great work! Hope linear fm and the fixed mod destination shortcut is still on the agenda 8)
Hoping for that as well. Would really take it to the next level! :)

blewis
Posts: 219
Joined: Sun Sep 29, 2013 7:11 pm

Re: Pro2 Main 1.1.8

Post by blewis » Sat Jul 25, 2015 12:21 am

1. Sequencer Track 1 can now be turned to 'Off': To disable, hold track select and press 'Notes: On' button to toggle

This was first on my list too!

1) I pulled up my paraphonic patch. Played paraphonic patch paraphonically.
2) Selected Track1 and turned Notes to OFF.
3) Played paraphonic patch paraphonically
4) Press play on the sequencer
5) No notes play at all. Sequencer moving. No sound.
6) scratch head (didn't I just tell the synth to _not_ have Track1 mess with the sound engine at all?)
7) Hit Misc Parms and put into Last Note Mono
8) Sequencer stops
9) Play patch monophonically. Works as expected
10) Press play
11) patch plays monophonically, sometimes, random notes trigger, then no notes trigger. can't figure out a pattern, but each time it works its way into not making sound anymore.

What?

I _really_ really want to play this paraphonic patch playing chords while having the sequencer modulate the feedback parameters in sync with the music.

How can I do that? I thought this fix was the key to doing that.

Can anyone help me figure out why this won't work?

cbmd
Posts: 346
Joined: Fri Sep 30, 2011 11:49 pm

Re: Pro2 Main 1.1.8

Post by cbmd » Sat Jul 25, 2015 4:19 am

Disabling track 1 is currently not working right. we are aware of it and it will be fixed before we release the next official OS. Shouldn't be too long now.
Carson Day
Technical Support
Dave Smith Instruments

blewis
Posts: 219
Joined: Sun Sep 29, 2013 7:11 pm

Re: Pro2 Main 1.1.8

Post by blewis » Sat Jul 25, 2015 11:53 am

np. We'll get there. Thanks for the quick response.

Benzebub
Posts: 118
Joined: Sun Jun 23, 2013 5:04 pm

Re: Pro2 Main 1.1.8

Post by Benzebub » Sat Jul 25, 2015 4:08 pm

Has the screen saver time been adjusted? I have tried to reset Globals and made sure to enable screen saver but mine does not seem to kick in.

elektraursula
Posts: 3
Joined: Tue Mar 05, 2013 12:21 pm

Re: Pro2 Main 1.1.8

Post by elektraursula » Sun Jul 26, 2015 5:43 pm

Hey!

Since the update I can't sequence the Pro2 by my Octatrack.
If I send notes the Pro 2 stuck by playing only one long everytime the sequence restarts. Also the Pro 2 behaves really slow with Program, Paramterchanges and the Display reacts really slow.

Anyone same Issues?

Greetings!

glynbo
Posts: 24
Joined: Sat Apr 25, 2015 6:33 pm

Re: Pro2 Main 1.1.8

Post by glynbo » Sun Jul 26, 2015 7:13 pm

Hi Pym,thanks for the new OS,and on a Sunday too.I know there are some new bugs and maybe more to be added but just having the midi delay sync working is a great thing.Looking forward to the next update and maybe a Manual addenum please.Many thanks Glyn.

glynbo
Posts: 24
Joined: Sat Apr 25, 2015 6:33 pm

Re: Pro2 Main 1.1.8

Post by glynbo » Sun Jul 26, 2015 8:13 pm

Is it me or is the delay`s midi sync still behaving badly when being controlled by an external sync in run mode?

Duskyfarer
Posts: 5
Joined: Tue Jul 28, 2015 9:02 pm

Re: Pro2 Main 1.1.8

Post by Duskyfarer » Tue Jul 28, 2015 9:10 pm

I tried to decouple Sequencer Track 1from the synth engine but no sound, only occasional random notes triggering when played legato. I pressed [Sequencer] button and turned off env trig (the parameter to the right), then I changed the sequencer trigger to key. This enabled me to play the notes correctly on the keyboard while running sequencer but couldn't play legato and portamento.

However, what I achieved with this semi-working mode was magical. I spent all my evening session jamming on the keyboard with the sequencer controlling filter and resonance. Please, please, do develop this function until it works smoothly with legato and portamento - it's going to be wonderful when it works as intended.

Post Reply