OS 1.1.0 Bugs

The Dave Smith Instruments Pro 2 Analogue Synthesizer

Moderator: Pym

blewis
Posts: 219
Joined: Sun Sep 29, 2013 7:11 pm

Re: OS 1.1.0 Bugs

Post by blewis » Sun Apr 12, 2015 3:53 pm

6 months

User avatar
Signifier
Posts: 124
Joined: Tue Nov 15, 2011 11:11 pm

Re: OS 1.1.0 Bugs

Post by Signifier » Thu Apr 16, 2015 8:30 pm

Any one else seeing imperfect sync when the Pro2 sequencer is slaved to external MIDI clock?

User avatar
Fuseball
Posts: 525
Joined: Mon May 23, 2011 9:06 am
Location: London
Contact:

Re: OS 1.1.0 Bugs

Post by Fuseball » Sun Apr 19, 2015 5:32 pm

Is "Revert Param" supposed to work for all panel controls?

I only ask as it doesn't appear to work for Filter 2's LP<->HP state. Revert All successfully resets the Filter 2 state but the state LEDs are not reset to their correct values.

Similarly, the Filter Routing control LEDs are not set back to their correct values when using Revert Param, although you can at least use Revert Param and a twist of the Filter Routing knob to set it back to its original value.

There may be others but these are the ones I noticed earlier.
Prophet'08 PE #3591 | Tetr4 #2088 | MEK PE #1180 | Jupiter 6 | Juno 60 | Moog Sub Phatty | MS-20 mini | random digital stuff

soundxplorer
Posts: 23
Joined: Fri Jan 30, 2015 4:30 pm

Re: OS 1.1.0 Bugs

Post by soundxplorer » Wed Apr 22, 2015 1:14 pm

Signifier wrote:Any one else seeing imperfect sync when the Pro2 sequencer is slaved to external MIDI clock?
viewtopic.php?f=35&t=6646

blewis
Posts: 219
Joined: Sun Sep 29, 2013 7:11 pm

Re: OS 1.1.0 Bugs

Post by blewis » Tue May 12, 2015 11:34 am

7 months

Trying to be patient and keep my internet control, but I'm starting to get perturbed.

I'm very excited about the Prophet-6 release so my other DSI products can get bug fixes.

User avatar
Signifier
Posts: 124
Joined: Tue Nov 15, 2011 11:11 pm

Re: OS 1.1.0 Bugs

Post by Signifier » Thu May 14, 2015 4:49 pm

soundxplorer wrote:
Signifier wrote:Any one else seeing imperfect sync when the Pro2 sequencer is slaved to external MIDI clock?
viewtopic.php?f=35&t=6646
I was trying to slave to an Elektron Analog Rytm, so its not going to be anything to do with the dire MIDI clock jitter generated by PCs etc. Is there a problem with sync at the Pro2's end for anyone?

ruddydarter
Posts: 5
Joined: Tue May 12, 2015 8:07 pm

Re: OS 1.1.0 Bugs

Post by ruddydarter » Sat May 23, 2015 9:21 am

Sometimes the pots don't catch up with the parameter values and remain unresponsive throughout the whole range in pass-through mode. Going to the offending parameter and changing the value via the encoder restores the dedicated pot's operation back to normal.

blewis
Posts: 219
Joined: Sun Sep 29, 2013 7:11 pm

Re: OS 1.1.0 Bugs

Post by blewis » Sat Jun 13, 2015 9:59 pm

8 months.

Pym looks like he's back on the case. Glad to have him back. Looking forward to getting some niggly items sorted.

blewis
Posts: 219
Joined: Sun Sep 29, 2013 7:11 pm

Re: OS 1.1.0 Bugs

Post by blewis » Fri Jul 17, 2015 12:24 pm

9 months

Hopefully coming soon. I have self imposed a wait period on any serious interest in the Prophet-6 until we see fixes for the Pro2

User avatar
F5D
Posts: 66
Joined: Fri Jan 02, 2009 5:33 pm
Location: Finland
Contact:

Re: OS 1.1.0 Bugs

Post by F5D » Fri Jul 17, 2015 9:10 pm

Looks like Pym and the "new DSP guy" are on the roll with the P12 updates coming out really fast now. I am sure the Pro-2 update will come next, after they get the new P12 OS working properly.
F5D @ Soundcloud: P12 Windscale Pads, Prophet 12 Canada (BOC), Prophet 12 Demo, Prophet '08 demo, Prophet '08 Textures - DSI Synths: Prophet 12, Prophet '08 PE, Pro-2

dcdcdcdc
Posts: 47
Joined: Fri Mar 01, 2013 7:21 am
Location: US

Re: OS 1.1.0 Bugs

Post by dcdcdcdc » Fri Jul 17, 2015 9:12 pm

Brian I will raise you one--

If DSI releases a Pro2 update that includes AT LEAST fixes to cue, playlist and sync, within the next 30 days, I will buy a darn P6. . . .out of pure joy. . . . :mrgreen:

Pym
Posts: 2197
Joined: Thu Mar 11, 2010 6:24 am
Location: San Francisco, CA
Contact:

Re: OS 1.1.0 Bugs

Post by Pym » Fri Jul 17, 2015 10:20 pm

I'm not sure I can fix the sync issue where it glitches a bit during the transition but I'm looking into it. Already fixed the playlist save bug and another one related to cue. You should see an OS update within 30 days for bug fixes and one later on with some other improvements
dcdcdcdc wrote:Brian I will raise you one--

If DSI releases a Pro2 update that includes AT LEAST fixes to cue, playlist and sync, within the next 30 days, I will buy a darn P6. . . .out of pure joy. . . . :mrgreen:
Chris Hector
https://soundcloud.com/iampym
Dave Smith Instruments

blewis
Posts: 219
Joined: Sun Sep 29, 2013 7:11 pm

Re: OS 1.1.0 Bugs

Post by blewis » Sat Jul 18, 2015 1:17 am

Thanks for the update on the progress!

Post Reply