URGENT!!!! Some digital sound leaking in my p12 patches.

The Dave Smith Instruments Prophet-12 Analogue Synthesizer

Moderator: Pym

User avatar
Tomavatars
Posts: 168
Joined: Thu Sep 26, 2013 11:16 am
Contact:

Re: URGENT!!!! Some digital sound leaking in my p12 patches.

Post by Tomavatars » Sun Aug 17, 2014 3:55 pm

I have the same spike on the I'm a Prophet and Kepler Patch.
Tried with the voxengo Span.
Do you believe I should change the board ?

RobbaSvenna
Posts: 177
Joined: Sun May 06, 2012 7:40 am

Re: URGENT!!!! Some digital sound leaking in my p12 patches.

Post by RobbaSvenna » Sun Aug 17, 2014 4:07 pm

Tomavatars, I suggest you contact the DSI support! Send them an audiofile and they'll help you out.

neonjung
Posts: 2
Joined: Sat Aug 09, 2014 5:54 pm

Re: URGENT!!!! Some digital sound leaking in my p12 patches.

Post by neonjung » Sun Aug 17, 2014 4:35 pm

I bought a P12 K just 5 days ago to find that the delays create this 11k noise for me also, although it's not too loud. I'm wondering if everyone has a small amount of this noise? Have people had new boards sent that completely eliminate it?

I've found a very simple quick fix is to just use the LPF on the delays to filter out the annoying noise.

Also the delays produce a tiny, almost inaudible, continuation of sound after all sounds should have ended. Again, it's not very noticeable or loud, but for such an expensive synth you would think the delays would be a little less, ummmm, sh*t than what they are.

Contemplating whether or not to send this back to the place I bought it from, get a new board from DSI or just live with it, hmmm

User avatar
BobTheDog
Posts: 1156
Joined: Sun Nov 20, 2011 8:49 pm

Re: URGENT!!!! Some digital sound leaking in my p12 patches.

Post by BobTheDog » Sun Aug 17, 2014 4:36 pm

Tomavatars wrote:I have the same spike on the I'm a Prophet and Kepler Patch.
Tried with the voxengo Span.
Do you believe I should change the board ?
It depends if it is audible, all P12s seem to have the spike when you look on a spectrum analyser but on some it is audible on others it isn't.

User avatar
Tomavatars
Posts: 168
Joined: Thu Sep 26, 2013 11:16 am
Contact:

Re: URGENT!!!! Some digital sound leaking in my p12 patches.

Post by Tomavatars » Sun Aug 17, 2014 5:44 pm

Okay. So I can't' really hear it, I just wanted to see if there were something on the spectrogram.
I'm not sure if I should say something about this to the support.

User avatar
BobTheDog
Posts: 1156
Joined: Sun Nov 20, 2011 8:49 pm

Re: URGENT!!!! Some digital sound leaking in my p12 patches.

Post by BobTheDog » Sun Aug 17, 2014 9:28 pm

It seems that the new version 1.1.4.1 lowers the spike as well.

User avatar
Fuseball
Posts: 525
Joined: Mon May 23, 2011 9:06 am
Location: London
Contact:

Re: URGENT!!!! Some digital sound leaking in my p12 patches.

Post by Fuseball » Sun Aug 17, 2014 11:18 pm

I don't believe it's doing anything as simple as lowering cutoff ranges. The spike, as well as being a lot less, is also behaving differently than before. I'm not seeing the persistent spike that i got even when no notes were playing on some patches.

I read Pym's comment as meaning that it wouldn't solve the issue for those with defective boards (which DSI have been replacing for some people on here) but would reduce the spike for the rest of us. Naturally, he wouldn't want to give those with genuinely defective boards false hope.

I wouldn't like to guess exactly what has been changed other than whatever is happening at that 11kHz frequency has been damped down or better isolated from the audio circuitry. For it to be partially fixable in an OS update like this does make it sound like its part of the digital side of the P12.
Prophet'08 PE #3591 | Tetr4 #2088 | MEK PE #1180 | Jupiter 6 | Juno 60 | Moog Sub Phatty | MS-20 mini | random digital stuff

User avatar
Fuseball
Posts: 525
Joined: Mon May 23, 2011 9:06 am
Location: London
Contact:

Re: URGENT!!!! Some digital sound leaking in my p12 patches.

Post by Fuseball » Mon Aug 18, 2014 10:14 am

Razmo wrote:But I'm still puzzled as to what can make a change in the frequency spectrum, without in some way changing something in the Voice OS instead of the Main OS.... I don't know how the engine connects of course, but as I've understood it, the Main OS is a PIC processor doing MIDI, Interface and telling the 6 DSPs what to do... so if only the DSP has influence on the actual sound directly, and the fix is made only on the Main OS, then the solution should be that the Main OS tell the DSPs to do something differently?
Does the P12 even have a separate voice OS? I think all our OS updates have been for the Main OS, even the ones that altered the triangle wave. I'm assuming that the Main OS must cover the entire digital side of the synth.

I'm as puzzled as you are about how the processors interact. :)

I think the people that were having severe 11kHz problems might see an improvement in the latest OS but judging by the severity of some of their spikes it would still be a noticeable problem for them. Until someone comments who has a defective board and has tried the OS update then we'll never know.

I share your concerns about fixing a hardware fault with software, although I am personally very grateful for the fix as it should see an improvement in the noise floor behaviour of everyone's P12.
Prophet'08 PE #3591 | Tetr4 #2088 | MEK PE #1180 | Jupiter 6 | Juno 60 | Moog Sub Phatty | MS-20 mini | random digital stuff

User avatar
BoBSwanS
Posts: 62
Joined: Fri Aug 01, 2014 3:43 pm

Re: URGENT!!!! Some digital sound leaking in my p12 patches.

Post by BoBSwanS » Mon Aug 18, 2014 11:06 am

My Module has the peak, i have been testing it with the help of this thread over the weekend. I will report back once i have completed the OS update

User avatar
elmquist
Posts: 3121
Joined: Thu Jun 24, 2010 8:35 am
Location: Denmark

Re: URGENT!!!! Some digital sound leaking in my p12 patches.

Post by elmquist » Mon Aug 18, 2014 1:16 pm

Razmo wrote:it seems to have it all in one OS file
The reason for that could be something as simple as wanting to update all sub systems at once thereby ensuring that compatible software versions are always installed in the instrument. Not a bad idea!

User avatar
BoBSwanS
Posts: 62
Joined: Fri Aug 01, 2014 3:43 pm

Re: URGENT!!!! Some digital sound leaking in my p12 patches.

Post by BoBSwanS » Mon Aug 18, 2014 5:57 pm

It seems i am still seeing this issue after the OS update, i updated and tested and it was visible, i calibrated the filters after a half hour of testing and still got it. I decided to try updating again but its still showing. The more i listen to the Kepler patch the more i think i may have some leakage


This is what Kepler looks like
Image


And this is what it sounds like
https://dl.dropboxusercontent.com/u/48574370/Kepler.wav

Edit- I change the audio file host



I could really do with a 2nd opinion before i commit to contacting support :?: :?:
Last edited by BoBSwanS on Mon Aug 18, 2014 6:06 pm, edited 1 time in total.

Raphie
Posts: 370
Joined: Thu Jul 22, 2010 10:34 am
Contact:

Re: URGENT!!!! Some digital sound leaking in my p12 patches.

Post by Raphie » Mon Aug 18, 2014 6:04 pm

not sure what the point is? you see a -80dB peak on a slope rolling off @-100dB?
BoBSwanS wrote:It seems i am still seeing this issue after the OS update, i updated and tested and it was visible, i calibrated the filters after a half hour of testing and still got it. I decided to try updating again but its still showing. The more i listen to the Kepler patch the more i think i may have some leakage


This is what Kepler looks like
Image


And this is what it sounds like
Kepler.wav



I could really do with a 2nd opinion before i commit to contacting support :?: :?:

Raphie
Posts: 370
Joined: Thu Jul 22, 2010 10:34 am
Contact:

Re: URGENT!!!! Some digital sound leaking in my p12 patches.

Post by Raphie » Mon Aug 18, 2014 6:12 pm

don't worry about it, loads of gear, doesn't look nice on a scope. If you can't hear it, it's not a problem

MakesSynthToMe
Posts: 29
Joined: Fri Nov 15, 2013 1:57 am

Re: URGENT!!!! Some digital sound leaking in my p12 patches.

Post by MakesSynthToMe » Mon Aug 18, 2014 7:14 pm

Here's the follow up. These are the same 4 patches I put up earlier in the thread.

11K is gone along with the high pitch sound it was producing. Sound wise Kepler, and just a plain sine were the worst as far as the ringing noise.
Needless to say the board replacement worked. I did update the old board to 1.1.4 before replacing. 11K was there albeit a lot lower,, and was not nearly as audible if audible at all.

-MS2M


Kepler AB OS 1.1.2
Image

Its a Prophet AB OS 1.1.2
Image

Sine Wave AB OS 1.1.2
Image

B1_P14 AB OS 1.1.2
Image

User avatar
BoBSwanS
Posts: 62
Joined: Fri Aug 01, 2014 3:43 pm

Re: URGENT!!!! Some digital sound leaking in my p12 patches.

Post by BoBSwanS » Mon Aug 18, 2014 7:18 pm

Raphie wrote:don't worry about it, loads of gear, doesn't look nice on a scope. If you can't hear it, it's not a problem
I'm not majorly worried, Just wanted a 2nd opinion on the audio really as i am a little unsure if its audible

MakesSynthToMe
Posts: 29
Joined: Fri Nov 15, 2013 1:57 am

Re: URGENT!!!! Some digital sound leaking in my p12 patches.

Post by MakesSynthToMe » Mon Aug 18, 2014 7:37 pm

It shipped with 1.1.1. which all I ran the same 3 patches and sine wave against, and it looked good.

I did replace the board myself but didn't notice anything other than the new board was a newer rev C, where the old one was rev B. I haven't sent the old one back yet but now that you mention it
I may go back open the P12 back up and snap a few pics to compare with the old.


hannasdeli
Posts: 54
Joined: Thu Feb 27, 2014 8:21 pm

Re: URGENT!!!! Some digital sound leaking in my p12 patches.

Post by hannasdeli » Tue Aug 19, 2014 6:07 pm

I had a board swap but i did not write down which revision it was. The reason was a super nasty random glitch in two of the voices (it was a digital glitch, i asume something related to one of the Sharks DSP) and it also had an unbearably high noise of the oscillators through the delay. I got another board and it was a huge improvement, but I noticed it tends to clip in some of the patches, specially when spread set to the max and Drive on. This did not happen in the previous one. There is another board on its way for that issue, although certainly minor than the first one.

I looked for the 11khz spike and I could only see it in a spectrum analyzer when I set up the resonance high in both filters (or was just the high pass?, can´t remember) and it is definitively there, but not really a problem, I don´t see it when playing normally.

One thing i noticed in both boards is a slow flanger-like type of granular overtone when switching the synth on.. and after a while playing it disappears. I have to assume it is an analog component warming up (the curtis chips?) somehow, because I can´t see how is that the result of a digital process. Probably it is part of the "character" of this machine.

I still think the P12 sounds awesome and what we have experienced are first batch problems i guess. Will post when i get the new voice board and see which revision i have installed now, and so forth.

Thanks for the information, just let´s not get paranoid hearing noises here and there. My MS20 mini is noisy and unpredictable as hell and i just love it.

Matthiola
Posts: 11
Joined: Wed Mar 05, 2014 8:56 am

Re: URGENT!!!! Some digital sound leaking in my p12 patches.

Post by Matthiola » Thu Aug 21, 2014 9:02 pm

My P12 has a faint 11khz noise on some patches, hardly noticable or measurable. However, boosting the high end with 15 dB reveals the 11khz peak quite clearly. I'm wondering if these new boards are completely clean or still have some residual noise.

anyanwu
Posts: 1
Joined: Fri Aug 29, 2014 6:04 am

Re: URGENT!!!! Some digital sound leaking in my p12 patches.

Post by anyanwu » Fri Aug 29, 2014 6:39 am

just got the p12. noticed 11k noise on the kepler preset. also heard on some others and an initialized patch with a sine wave.

the important part tho: I was using headphones when i noticed the noise, master volume was probably around 10%-15%. ran it through a spectrum analyzer and there it was. when i turned the master volume on the p12 all the way up (and preamp wayyy down) the spike pretty much remained at it's amplitude while the noise floor and the desired signal came up. at this point the 11k noise was about 5db above the noise floor, 100+db below the peak signal, and was inaudible. Idk it is pretty lame that the signal is there, but if you are performing or recording and only using 10% of the headroom on your synth maybe you should think about how silly that is first. mine definitely doesn't sound like some of the extreme examples on here, but if you are on the fence about asking dsi for a board maybe try turning the synth up lol.

ps can someone verify this and maybe offer an explanation as to why the signal's amplitude seems unaffected by the master volume?

Post Reply