Prophet 12 Main OS 1.2.26

The Dave Smith Instruments Prophet-12 Analogue Synthesizer

Moderator: Pym

Post Reply
Pym
Posts: 2197
Joined: Thu Mar 11, 2010 6:24 am
Location: San Francisco, CA
Contact:

Prophet 12 Main OS 1.2.26

Post by Pym » Tue Aug 06, 2013 2:47 am

ALWAYS BACKUP YOUR IMPORTANT WORK VIA SYSEX DUMP BEFORE ATTEMPTING ANY OS UPDATES!!
Not that we're expecting bad things to happen, but always better safe than sorry. Just remember, you're never going to say to yourself "Man, I wish I hadn't backed that up..."

We do not recommend using the following MIDI interfaces for sysex transfers as we have had multiple users experience problems with them:
  • Native Instruments Maschine
  • Digidesign Mbox/Mbox2
  • Digidesign 001/002
  • CME U2MIDI
Updating the Prophet 12 OS on a PC
Updating the Prophet 12 OS on a Mac

The OS updates can be installed in any order, just power cycle in between each update.

To check if the OS update was properly installed, go to the global menu by hitting the 'Global' button and the OS version is displayed at the top of the 3rd column

If your OS update failed:
  • Update your MIDI drivers for your MIDI interface to the latest or last known stable version
  • Try alternate speed settings: transfer speed settings as low as 25% and as high as 100% have worked for some users when 80% did not
  • Try an alternate MIDI interface. The M-Audio MIDI Sport Uno works well here and is relatively cheap
  • In Windows with MIDI OX on Windows XP: Try doubling or quadrupling the Size setting to start, and halving/doubling the number of buffers
  • Search google and/or forums for the company that produces your MIDI interface to see if other users are having similar problems with Sysex transfers and whether there is a solution specific to your interface
  • If you are on Windows XP, try another OS or machine. Although it's not ideal, we have had less problems with Mac OSX and Windows 7. Windows XP has known issues with sysex transfers
INSTALLATION NOTE: It is recommended to recalibrate the filters and reset globals after installing a Main OS update. These functions can be found in the global menu

WARNING: If loading OS from factory OS 1.0 via USB, the first 4 programs will be overwritten due to a boundary check error. This will only happen once as it is fixed in the first OS. You can prevent this is loading the OS using the normal MIDI ports, or simply copy/save the first 4 programs temporarily and copy them back after loading the OS.

Main OS 1.2.26
  1. NOTE: Reset globals or enable the screen saver global after installing this OS unless you absolutely do not want it on to save your OLED lifespan
  2. Release candidate
  3. Fixed bug: Exp FM bug
Main OS 1.2.25
  1. NOTE: Reset globals or enable the screen saver global after installing this OS unless you absolutely do not want it on to save your OLED lifespan
  2. Release candidate
  3. Fixed bug: Show with passthru pot mode not working right
Main OS 1.2.24
  1. NOTE: Reset globals or enable the screen saver global after installing this OS unless you absolutely do not want it on to save your OLED lifespan
  2. Release candidate
  3. Fixed bug: Mod drive bug crept back in somehow
Main OS 1.2.22
  1. NOTE: Reset globals or enable the screen saver global after installing this OS unless you absolutely do not want it on to save your OLED lifespan
  2. Release candidate
  3. Added delay feedback mode param that swaps between old and new versions of delay feedback. Use 4th tab in delay section, changes param for all delays
  4. Fixed bug: Exponential feedback not clipped the same way it was before
  5. Fixed bug: Mods with source set to off, amount and destination set to valid numbers, sometimes affecting sound incorrectly
Main OS 1.2.20
  1. NOTE: Reset globals or enable the screen saver global after installing this OS unless you absolutely do not want it on to save your OLED lifespan
  2. Release candidate
  3. Changed delay to be a bit more wild than previous 1.2 OSes
Main OS 1.2.19
  1. NOTE: Reset globals or enable the screen saver global after installing this OS unless you absolutely do not want it on to save your OLED lifespan
  2. Release candidate
  3. Fixed bug: Returning from OLED sleep mode causing random problems
Main OS 1.2.18
  1. NOTE: Reset globals or enable the screen saver global after installing this OS unless you absolutely do not want it on to save your OLED lifespan
  2. Release candidate
  3. Add NRPN 77 for Osc all FM mode
  4. Fixed bug: Alternate tunings not pitched correctly
  5. Fixed bug: Osc 3 slop not working
  6. Fixed bug: Sysex messages less than 3 bytes causing problems
  7. Fixed bug: Cannot have separate BPMs between layers
Main OS 1.2.15
  1. NOTE: Reset globals or enable the screen saver global after installing this OS unless you absolutely do not want it on to save your OLED lifespan
  2. Release candidate
  3. Fixed bug: Osc Slop All modulator affecting Drive, Drive not assigned
Main OS 1.2.13
  1. NOTE: Reset globals or enable the screen saver global after installing this OS unless you absolutely do not want it on to save your OLED lifespan
  2. Optimized further to prevent processor overloads when Linear FM maxed in mod matrix
  3. Fixed bug: Sub Osc affected incorrectly by slop
Main OS 1.2.12
  1. NOTE: Reset globals or enable the screen saver global after installing this OS unless you absolutely do not want it on to save your OLED lifespan
  2. Delay behavior changed slightly to act more like previous versions
  3. Linear FM now calculated in mods section
    • NOTE: When Linear FM is used in the mod section you can overload the processor, so you have to be careful. When maxing everything out you will get an unpleasant digital crackling
  4. Fixed bug: P12 not loading alternate tunings file correctly
  5. Fixed bug: Some mods not loading correctly from old sounds
  6. Fixed bug: Copying layer B-A does not refresh voices correctly
  7. Fixed bug: When MIDI notes arp on, sending bad note off in some cases, now sends 'all notes off' instead
Main OS 1.2.10
  1. Fixes voice dropouts
Main OS 1.2.9.4
  1. NOTE: Reset globals or enable the screen saver global after installing this OS unless you absolutely do not want it on to save your OLED lifespan
  2. Added production alternate tunings file since the other was not working
  3. Fixed bug: Oscillators getting into a bugged state randomly
  4. Fixed bug: Mod wheel occasionally sending MIDI Reset messages
  5. Fixed bug: Alt tunings not working after setting basic patch
Main OS 1.2.9.2
  1. NOTE: Reset globals or enable the screen saver global after installing this OS unless you absolutely do not want it on to save your OLED lifespan
  2. Alternate tunings/scales added. You can load these in the globals section after sending the attached MIDI sysex file for alternate tunings. Read the Prophet 6 manual for more information
  3. Linear FM (DX7 style). An additional parameter has been added in the Osc section to toggle between exponential and linear FM modes
  4. Unison now selectable from 1-12 voices or in split/stack from 1-6 voices
  5. Arp can now output the MIDI notes it is playing. A global has been added to enable this
  6. New mod destinations added:
    1. Osc 1-4 Slop
    2. Osc All Shape Mod
    3. Delay All Time
  7. LFO and Envelope destinations can now be assigned by holding down the LFO/Envelope button and moving the destination you wish to set, in the same way the mod destination button works
  8. Added global to toggle MIDI program change messages being sent
  9. Added global to turn off screen saver mode
  10. Fixed bug: Delay buffer overruns minimized to fix audio dropouts and some clipping issues
  11. Fixed bug: BPM calculation smoothed to improve delay performance from quick tempo changes or an inconsistent clock source
  12. Fixed bug: Delay buffers now cleared when changing programs
  13. Fixed bug: Show response not working correctly when pots set to passthru
  14. Fixed bug: Screen glitches when coming back from sleep mode
  15. Fixed bug: Program Volume (CC#7) no longer sent when MIDI send off
  16. Fixed bug: Crash/Lockup when receiving clock in MIDI: Slave Thru mode
  17. Fixed bug: Arp playing incorrect notes in certain combinations of params/keys
  18. Fixed bug: In some cases cannot switch programs from a DAW/Host
  19. Fixed bug: BPM acquisition time improved
Main OS 1.2
  1. Production OS, essentially the same as 1.1.4.1
Main OS 1.1.4.1
  1. Added recovery mode in case sound corrupt and causing freeze on startup: hold 'Arp Hold' while booting. NOTE: This is DESTRUCTIVE and will destroy the preset that is loading so don't use it unless it's corrupt and unrecoverable
  2. Fixed bug: Noise phasing when holding multiple keys with heavy noise
  3. Fixed bug: Some cases where assigning a mod source resulted in the entire list being filled with that source
  4. Fixed bug: Key scanning issue when E3, A3, B3 and C4 played together
  5. Fixed bug: '?' character added
  6. Fixed bug: CCs sent to P12 not updating voice unless split or stack on
  7. Fixed bug: Mod matrix sort behavior incorrect on program change
  8. Fixed bug: Voices 7-12 not responding to BPM adjustments correctly in some cases
  9. Fixed bug: Slider 1 pressure transmitting as CC17 instead of CC16 as intended
  10. Fixed bug: Delay filter bug where if one delay has HP enabled, the following delays have a bug with LPF
Main OS 1.1.2
  1. Fixed bug: When local control off, program change messages not sent
  2. Fixed bug: Arp not starting on correct note when multiple octaves in up or up+down modes
  3. Fixed bug: Reset globals not resetting multi mode
  4. Fixed bug: Crash when slave thru used and incoming MIDI coming over hard MIDI port
Main OS 1.1.1
  1. Production candidate
  2. Added NRPN for layer loading to 500 for program and 501 for bank
  3. Fixed bug: Arp hold behavior tightened up when multi mode on
  4. Fixed bug: Several small bugs related to arp lock
  5. Fixed bug: Key scan/timing bug causing some notes not to sound in very particular circumstances
  6. Fixed bug: Program loads over sysex not jumping to new program location
  7. Fixed bug: Mod source + keyboard changing mod assignment on key up+down making it difficult to assign correctly
  8. Fixed bug: Layer B not sending NRPNs when multi mode off
  9. Fixed bug: Note velocity of 0 no longer allowed in arp lock screen
  10. Fixed bug: Tightened up case where changing multiple params at once slows down arp bpm
Main OS 1.0.3.0
  1. Production candidate
  2. Fixed bug: Several bugs relating to hung notes and/or hold states with the arp and multi mode state transitions
  3. Fixed bug: Voice stealing issue
  4. Fixed bug: Several small bugs with lock notes playback
  5. Fixed bug: Some MIDI messages not responding correctly while Multi on
  6. Added some visual indication to help understand what 'Capture Arp' is doing: now the text only appears if you have notes held or an arp playing back
Main OS 1.0.2.16
  1. WARNING: If loading OS via USB from OS 1.0, the first 4 programs will be overwritten due to a boundary check error. This does not occur if you're loading from OS 1.0.1.2 or higher
  2. Fixed bug: distortion not updating
  3. Fixed bug: several bugs related to multi mode MIDI response
  4. Fixed bug: triangle waveshape smoothed and tweaked
  5. Added NRPNs for new params:
    • Delay 1 LPF - 192
    • Delay 1 HPF - 193
    • Delay 1 Filter Mode - 194
    • Delay 1 Pan - 427
    • Delay 2 LPF - 200
    • Delay 2 HPF - 201
    • Delay 2 Filter Mode - 202
    • Delay 2 Pan - 428
    • Delay 3 LPF - 208
    • Delay 3 HPF - 209
    • Delay 3 Filter Mode - 210
    • Delay 3 Pan - 429
    • Delay 4 LPF - 216
    • Delay 4 HPF - 217
    • Delay 4 Filter Mode - 218
    • Delay 4 Pan - 430
    • Arp Lock On/Off - 295
    • Arp Note - 301-333
    • Arp Velocity - 334-366
Main OS 1.0.2.11
  1. WARNING: If loading OS via USB from OS 1.0, the first 4 programs will be overwritten due to a boundary check error. This does not occur if you're loading from OS 1.0.1.2 or higher
  2. Added filter to each delay line, selectable between highpass and lowpass filters
  3. Added delay parameter to each delay line
  4. Osc Slop to all oscillators is now a mod destination
  5. Added lock arp functionality:
    • In the arp screen, holding an arp and turning lock notes to 'Normal' saves the arp in the locked arp params
    • While an arp is locked, pressing a key transposes the arp to that note using the first note in the locked arp as the 'root' note: so if you record an arp of C4, E4, G4 and then press F5, the arp will play back F5, A5, C5
    • While locked arp is on, in the arp screen pressing the 4th soft button labelled 'Edit Arp' brings up a screen where you can edit the locked values of the arp
  6. Multi mode added
    • MIDI channels can be set in the global param screen, with layer B being the next channel after the master MIDI channel
    • Multi works slightly differently in the P12 than our older instruments: when you use MIDI and a preset is stacked, it will only play the voice you want to play over MIDI... so in this way you could use the P12 keyboard to play a stacked sound, or use a MIDI keyboard to play a single layer
    • When multi is on and the P12 is not in stack or split mode, playing from the keyboard is locked to 6 voices per layer
  7. Poly Aftertouch over MIDI implemented, uses aftertouch mod destination to control individual note mod behavior
  8. Several tweaks to the oscillators to make them more smooth/consistent
  9. Fixed bug: Some program buttons active in global screen causing odd behavior with soft encoders
  10. Fixed bug: Tap tempo always setting tempo on 5th hit, not timing out as it should
  11. Fixed bug: Some cases where artifacts and/or clicking occurs when modulating the delay params with LFOs or other mods
  12. Fixed bug: Some cases where hung notes could occur when layer A/B triggered and modes changed
Main OS 1.0.1.5
  1. WARNING: If loading OS via USB from OS 1.0, the first 4 programs will be overwritten due to a boundary check error. This does not occur if you're loading from OS 1.0.1.2 or higher
  2. Tweaked handling of encoders, faster movements should track much better now
  3. Added Next/Prev param buttons in all osc/lfo/env/delay screens to allow navigation through all params in each section
  4. Separated Feedback and Highpass filter into their own screens
  5. Incoming valid sysex now brings the display out of sleep mode
  6. Fixed bug: Hung notes in unison mode in certain combinations
  7. Fixed bug: Going to all osc/lfo/env/delay screens not correctly bringing up the last changed param
  8. Fixed bug: Mod for pan position had reversed L/R values
  9. Fixed bug: Added timeout to program loads to prevent glitches
  10. Fixed bug: Random LFO not syncing correctly to external sync
  11. Fixed bug: LFO not restarting at correct phase when externally synced
  12. Fixed bug: Delay times not accurate for dotted values, incorrectly calculated as triplets
  13. Fixed bug: Hitting global button in write screen does not exit as intended but global LED is lit causing unexpected behavior
  14. Fixed bug: Tap tempo button not resetting after program change
  15. Fixed bug: Changing playlist bank not resetting playlist subset to 0
  16. Fixed bug: Some params incorrectly displaying knob graphic rather than text box
  17. Fixed bug: Show not working correctly in some cases when pots in Passthru mode
Main OS 1.0.1.2
  1. WARNING: If loading OS via USB, the first 4 programs will be overwritten due to a boundary check error
  2. Fixed bug: First 4 programs overwritten after USB OS load
  3. Fixed bug: OLED timeout not working
  4. Fixed bug: Incoming notes not responding to velocity correctly
  5. Fixed bug: Volume pot not sending changes to MIDI CC#7 as intended
  6. Fixed bug: Last note priority not handled correctly when holding chords and releasing the middle note (resetting to low rather than high note if high pressed last). Note: only two notes are tracked so otherwise behaving as intended
  7. Fixed bug: Screen refresh on all osc/lfo/env/delay screens causes param reset to Osc 1 Pitch (param 0)
  8. Fixed bug: Mod dest + AM/FM pots when all osc selected not selecting correct all osc destination
  9. Fixed bug: MIDI transmit not ignoring bus if busy causing some odd behavior in certain MIDI slave situations (notably with windows XP under parallels)
  10. Fixed bug: Added catch to MIDI Sysex over UART to prevent rare stall case
  11. Fixed bug: Issue with single byte USB MIDI case causing problems with certain OS/DAW combinations (notably OSX sysex transmissions)
  12. Fixed bug: Some variables not clearing correctly when switching sysex cable in globals
Attachments
P12M_Main_1.2.26.syx
P12 Module Main OS 1.2.26
(585.51 KiB) Downloaded 121 times
P12K_Main_1.2.26.syx
P12 Keyboard Main OS 1.2.26
(585.51 KiB) Downloaded 277 times
AltTunings1-16_17May2015.syx
16 Alternate Tunings for Prophet 6/12
(6.38 KiB) Downloaded 304 times
P12M_Main_1.2.0.syx
P12 Module Main OS 1.2
(585.51 KiB) Downloaded 143 times
P12K_Main_1.2.0.syx
P12 Keyboard Main OS 1.2
(585.51 KiB) Downloaded 215 times
P12_Programs_v1.1c_FACTORY.syx
Prophet 12 Presets for overwriting FACTORY banks
(455.55 KiB) Downloaded 878 times
Last edited by Pym on Wed Oct 30, 2013 1:47 am, edited 3 times in total.
Chris Hector
https://soundcloud.com/iampym
Dave Smith Instruments

markwalkerjr
Posts: 39
Joined: Sun May 08, 2011 5:53 pm

Post by markwalkerjr » Tue Aug 06, 2013 11:06 am

Pym,

Per my previous post to the forum, my prophet 12 is still starting up on bank 1, patch 34 "Zepher Touch" after the update and not the last patch I was working on before shut down or even the first patch in the first bank. Very strange.

Mark

Silky Night Music
Posts: 46
Joined: Sat Jul 20, 2013 7:36 pm

Post by Silky Night Music » Tue Aug 06, 2013 1:57 pm

Thank you, will update tonight

digidisiggi
Posts: 10
Joined: Tue Jul 30, 2013 7:04 am

Post by digidisiggi » Tue Aug 06, 2013 8:59 pm

Thanks Chris, will update tomorrow in my studio.

Best, Siggi :D

User avatar
Fuseball
Posts: 525
Joined: Mon May 23, 2011 9:06 am
Location: London
Contact:

Post by Fuseball » Tue Aug 06, 2013 9:57 pm

markwalkerjr wrote:Pym,

Per my previous post to the forum, my prophet 12 is still starting up on bank 1, patch 34 "Zepher Touch" after the update and not the last patch I was working on before shut down or even the first patch in the first bank. Very strange.

Mark
I'm guessing that will be in the next update. I get the feeling this was more a quick release to fix the velocity bug (and a couple of other things).

Still a few niggling things outstanding (like the startup patch) but I'm so happy I can finally get it working in my studio. :)

Great work Chris!
Prophet'08 PE #3591 | Tetr4 #2088 | MEK PE #1180 | Jupiter 6 | Juno 60 | Moog Sub Phatty | MS-20 mini | random digital stuff

Pym
Posts: 2197
Joined: Thu Mar 11, 2010 6:24 am
Location: San Francisco, CA
Contact:

Post by Pym » Tue Aug 06, 2013 10:45 pm

Yeah, that wasn't critical and I wanted to push the other bugs first. It's annoying but very low in terms of being critical, just medium visibility. So it needs to be improved but won't be until the next update
Fuseball wrote:
markwalkerjr wrote:Pym,

Per my previous post to the forum, my prophet 12 is still starting up on bank 1, patch 34 "Zepher Touch" after the update and not the last patch I was working on before shut down or even the first patch in the first bank. Very strange.

Mark
I'm guessing that will be in the next update. I get the feeling this was more a quick release to fix the velocity bug (and a couple of other things).

Still a few niggling things outstanding (like the startup patch) but I'm so happy I can finally get it working in my studio. :)

Great work Chris!
Chris Hector
https://soundcloud.com/iampym
Dave Smith Instruments

markwalkerjr
Posts: 39
Joined: Sun May 08, 2011 5:53 pm

Post by markwalkerjr » Wed Aug 07, 2013 12:25 am

Not a problem Pym, I agree it is just a minor annoyance and nothing I mind waiting for. Since it is the one actual bug I noticed in the way I use the synth I just thought it was worth bringing up. Thanks again for pushing this out to the users and I look forward to many years with this synth in the arsenal.

Mark

mekohler
Posts: 56
Joined: Wed Jun 05, 2013 3:36 pm

Post by mekohler » Wed Aug 07, 2013 2:24 pm

I'm curious as to what language the OS is written in? How much space left for the OS do you have? Are you guys maxed out?

digidisiggi
Posts: 10
Joined: Tue Jul 30, 2013 7:04 am

Post by digidisiggi » Wed Aug 07, 2013 3:33 pm

Hi Chris,

now i did the update, but all the Factory Banks are gone. The User Banks still there. What did i wrong?

Anybody else who did the update?

Siggi

rutabaga40
Posts: 23
Joined: Thu Jul 04, 2013 5:41 pm

Post by rutabaga40 » Thu Aug 08, 2013 12:29 am

um, help me out here...WHERE can i find said update? :shock:

cbmd
Posts: 346
Joined: Fri Sep 30, 2011 11:49 pm

Post by cbmd » Thu Aug 08, 2013 12:39 am

look up ^ first post of this thread
Carson Day
Technical Support
Dave Smith Instruments

rutabaga40
Posts: 23
Joined: Thu Jul 04, 2013 5:41 pm

Post by rutabaga40 » Thu Aug 08, 2013 10:21 am

Thanks, Carson. I wasn't crazy...the data file at the bottom of the post wasn't appearing the first few times I viewed the page. I randomly refreshed, and there it was (I had tried to load page in both Chrome and Safari). Strange, but I have it now, Thanks!

RonF
Posts: 36
Joined: Thu Oct 27, 2011 10:19 pm
Location: San Diego, CA USA

Post by RonF » Thu Aug 08, 2013 6:18 pm

rutabaga40 wrote:Thanks, Carson. I wasn't crazy...the data file at the bottom of the post wasn't appearing the first few times I viewed the page. I randomly refreshed, and there it was (I had tried to load page in both Chrome and Safari). Strange, but I have it now, Thanks!
No you are not crazy...same thing happened to me, and happens frequently. I use Safari on 10.8.4. Every time I login to DSI Forums, I get basically two "layers" that I need to drill down into to get to actual content. I can Google search DSI Forums, and click on the forum index link. Then I see the index, and click on, say, Prophet 12 sub-forum link, but if I click on any post, I am frequently brought back UP to the forum Index! THEN if I drill down to a post in a sub-forum, I can see the content. This is a FREQUENT occurrence!

Sometimes, as happened yesterday when I was seeking to download the P12 update, even after going through all of the above...I don't see links to downloads or other attachments in posts, until I do something like click New Reply or New Thread....and then I get bounced back up to the top Index AGAIN....and drill down down again where I can see the full content.

DSI Forums has been like this, for me, for a while now......many months if not a year. No other forum I visit exhibits this behavior on the same computer (and I visit a LOT of forums!). Not sure what it is....but I've managed to live with it, now that I know how to navigate it. But it IS a PITA. To the mods or admin...be aware....its a real thing!

User avatar
elmquist
Posts: 3121
Joined: Thu Jun 24, 2010 8:35 am
Location: Denmark

Post by elmquist » Thu Aug 08, 2013 6:39 pm

@RonF: Have you tried firefox or one of the other browsers? Also it could be related to the caching server you see the web through. There are many ways web content can go wrong and not all of them are under ones own control. Then there is the quality of the forum software and its underlying hosting platform.

RonF
Posts: 36
Joined: Thu Oct 27, 2011 10:19 pm
Location: San Diego, CA USA

Post by RonF » Thu Aug 08, 2013 7:05 pm

elmquist wrote:@RonF: Have you tried firefox or one of the other browsers? Also it could be related to the caching server you see the web through. There are many ways web content can go wrong and not all of them are under ones own control. Then there is the quality of the forum software and its underlying hosting platform.
No...I don't need a workaround, I've learned how to navigate it. And I surely don't think I should have to need another browser, etc, just to navigate DSI Forums. The simple fact is...I don't have this issue with any other forum. Its a DSI thing, only, for me.

rutabaga40's post just validated my experiences on the forum, and helped me realize I'm not the only one. With that in mind....admin should be aware. The Forum can be very dodgy on Safari 10.8.4. Otherwise, my Internet experience on my MBP is flawless.

Thanks none-the-less for your reply and advice!

User avatar
elmquist
Posts: 3121
Joined: Thu Jun 24, 2010 8:35 am
Location: Denmark

Post by elmquist » Thu Aug 08, 2013 8:05 pm

RonF wrote:Otherwise, my Internet experience on my MBP is flawless.
Its all about one's view on and attitudes towards the tools one use. Being a Linux user myself I have to be open to alternative tools when things are not working. Compare this to the perhaps more polished nature of things on the Mac platform. If there is one seed I would like to plant in your mind its as simple as this: please always be prepared to question the quality of the tools you use.

With that said I must say there are definitely room for improvement on this forum. Hopefully DSI and the current administrator manage to work out a deal so that DSI pays for a better quality hosting while getting more control over their parts of the forum. Starting up a forum.davesmithinstruments.com site will not be as good seen from community building and community preserving side of things.

Okay back to P12 discussions and loads of gear envy from here (though I am really after a Prophet 4 desktop module)!

creativespiral
Posts: 9
Joined: Fri Jul 12, 2013 6:45 pm
Location: United States

Post by creativespiral » Thu Aug 08, 2013 8:19 pm

I think maybe you just have to be logged in to see the download content??? (not viewing as a guest..) I just logged in and now I can see the download link.
PEK / P12 User

User avatar
elmquist
Posts: 3121
Joined: Thu Jun 24, 2010 8:35 am
Location: Denmark

Post by elmquist » Thu Aug 08, 2013 8:32 pm

Spot on, creativespiral! For a long time the forum has been closed for the public and one had to log in to read the posts. This has been changed back again to public access. And yes the attachments are only visible when logged in so that could explain the behavior people are seeing.

Welcome to the forum. Nice gear collection you have there (wrote the Evolver addict)! :-)

Pym
Posts: 2197
Joined: Thu Mar 11, 2010 6:24 am
Location: San Francisco, CA
Contact:

Post by Pym » Thu Aug 08, 2013 9:51 pm

Yes, you have to be logged in.

I normally leave a tab open with me logged in since if you open another window or tab and go to the site you're logged out initially until you click a forum link. It's annoying, but that's what it is for now. I'm glad it's an unofficial forum =)
creativespiral wrote:I think maybe you just have to be logged in to see the download content??? (not viewing as a guest..) I just logged in and now I can see the download link.
Chris Hector
https://soundcloud.com/iampym
Dave Smith Instruments

digidisiggi
Posts: 10
Joined: Tue Jul 30, 2013 7:04 am

Post by digidisiggi » Fri Aug 09, 2013 12:49 am

Chris,

no hint for my problem? You already got pm from me.

Post Reply